Constitution status invalid

Hi, I’m trying to register my project: GitHub - vadkutsen/obiswap: Uniswap clone for Obscuro testnet but the constitution status is invalid. I assume it’s because I pushed the tea.yaml file directly to the main branch. I removed the tea.yaml and re-added it again via a PR which is merged now. How can I re-validate my project?

1 Like

Hello, search for your project again and it should work.

Still no luck. I re-searched my project and re-added the tea.yaml file but still see the “invalid” status


And I got this email again

You have to update the git source url

I’m not sure how to do that. Can you please guide me?

  1. Navigate to your package directory.

  2. Open the package.json file.

  3. Update the “repository” field: Within the package.json file, locate the “repository” field and update the URL.

  4. Save the changes

  5. Publish the updated package

“repository”: {
“type”: “git”,
“url”: “GitHub - vadkutsen/obiswap: Uniswap clone for Obscuro testnet
}

Thanks a lot. Done. But the status didn’t change on the Tea page. Should I just wait for now?

Yes, it should be indexed in 24h

1 Like

Still no luck. I tried to re-validate the project but it failed again

Could you send the npm link and your tea username?

My tea account username is vadkutsen. What is the mom link?

Sorry, typo, auto correct, can you send the npm link please?

This one? obiswap - npm Or this one? GitHub - vadkutsen/obiswap: Uniswap clone for Obscuro testnet

We have a fix in place, for projects published in the last few days try again in 48h.

1 Like

We have applied a fix for the invalid source URL error. Please publish a new version of your package today so that it can be re-indexed and you can successfully register your project.

Done publishing a new version.

Successfully registered my project. Thanks a lot!