My OOS project can not add to TEA

i have two project:
npm: https://www.npmjs.com/package/ranui
github: https://github.com/chaxus/ran/tree/main/packages/ranui

but can not add to TEA
how to solve this problem?
Thank you very much

Hi! Could you repeat the registration process?

step 1:


step 2:

step 3:
to ran/packages/ranui at main · chaxus/ran · GitHub mian branch add tea.yaml:

# https://tea.xyz/what-is-this-file
---
version: 1.0.0
codeOwners:
  - '0x2D739EBb132564d3dC9D7A2Ecae673736B79295B'
quorum: 1

Then it turns out that the added package is invalid

I think it’s Invalid because you didn’t publish tea.yaml to the new version I had saw it as a code, I didn’t found it in your package.


I think it says something in here

You will need to download your project’s constitution file, and manually commit the file to your project’s repository.

So I understand that just upload it to the project’s repository.

But I think you have a point. I’m going to give it a try, and I’ll get back to you if I get any results

Thank you for your reply :grinning:

1 Like

The tea.yaml file should ONLY be added to the project repository, not published to the package.

1 Like

Thank you for your reply. I won’t published to the package. But I still don’t understand why it doesn’t work :face_exhaling:

1 Like

I tried again, But still not.

How i can mad my project

I found out why, because the project structure of both npm packages is monorepo. At present, this structure can not be registered successfully.

Could you give me your email (in DM) when monorepos will be supported the team will contact you and help you in registering your projects.

1 Like

81380@163.com

Thank you very much. I am also a developer. If there is any need, I can also provide support. I hope TEA will get better and better.

1 Like