No valid URL detected on project repository page - it still repeats

My OSS project finally showed up, but I still got error “No valid URL detected on project repository page” despite registering the repository address properly.
I saw on the forums that many other people were experiencing the same error, and the team had fixed the issue and told them to deploy a new version to fix it.

However, even though I released the new version, I am still getting the same error. Do I have to wait another 24 hours or so?

2 Likes

Hello, yes, please check back in 24h.

1 Like

I’m still having problems now.

We are currently working on resolving this issue. Additionally, please ensure that the repository URL format is correct:

“repository”: {
“type”: “git”,
“url”: “https://github.com/username/repository”
},

Also, please consider that it might take a bit longer for the project to be indexed.

Hi @maestlin,

Are you sure the indexer neglects this format below?

“repository”: {
“type”: “git”,
“url”: “git+https://github.com/username/repository.git”

Don’t neglect, but a valid URL would be:
“repository”: {
“type”: “git”,
“url”: “https://github.com/username/repository.git”

Looking at other projects, it recognizes this format as well. However, it seems that new projects are not properly recognized.

Thanks for the reply @dora-0

Do you have any suggestions to overcome this situation?

I see lots of “created-for-airdrop-farming-purposes” and useless packages indexed very well.

Time is running out, and it still doesn’t work.

Still no solution for this? i had to update to this:

Don’t neglect, but a valid URL would be:
“repository”: {
“type”: “git”,
“url”: “https://github.com/username/repository.git”

from this:

“repository”: {
“type”: “git”,
“url”: “git+https://github.com/username/repository.git”

still nothing

At the moment you will just have to wait, we are working on fixing these issues and speeding up the process.

@maestlin my project finally shows the url but still not validating, i used the validate constitution button but i get this

a screen shot to my project

image

Perform a hard refresh on your browser and try to validate your project once more.

Same issue and error message

“Project was not found in store. Please contact support.

Could you send a full screen screenshot?